API real-time data (websockets, webhooks) lags around prime-time - Fixed??

  • 1
  • Question
  • Updated 6 months ago
  • Answered
A few months ago there was a thread on here (now archived) about the lag in receiving real-time data from the API.

I just checked my log files for yesterday and there was zero lag during rush now (the events were being received in near-real-time). 

It was the day before a holiday, and there was hardly any traffic, so I'm not counting chickens before they hatch -- but wanted to ask Automatic here: have all the previously mentioned infrastructure upgrades taken place that were supposed to address the API lag?

Photo of Matt Farley

Matt Farley

  • 1,434 Points 1k badge 2x thumb

Posted 9 months ago

  • 1
Photo of Amy


  • 68,950 Points 50k badge 2x thumb
Hi Matt - I'm not sure what happened with the other topic. I don't recall archiving it but perhaps I did inadvertently or maybe someone on my team did. ?? Anyhow, glad to hear the response time has improved. As far as I know, the work -- which has been significant -- is still in progress but some of it is done. 
Photo of Matt Farley

Matt Farley

  • 1,434 Points 1k badge 2x thumb
Unfortunately, as of August 27th, we're back to laggy websocket events :( ... I keep a log of all the events, including timestamps. Up until Aug 27 everything arrived in less than 60 seconds. As of Aug 27, events are between 1 and 30 minutes late, consistently. Did Automatic change something in their infrastructure around Aug 27? :(
Photo of Derrick S.

Derrick S., Official Rep

  • 6,144 Points 5k badge 2x thumb
Hi Matt,

Please contact developer@automatic.com for assistance with this.