Automatic Classic and License+ connection issue on Galaxy S8.

  • 2
  • Problem
  • Updated 11 months ago
Why does the License+ app give me an error box that says "Cannot authenticate" "Do you have the right version of Automatic installed?" when I try to connect it to my Automatic Classic App? I have a gen 2 installed in my car and am using a Galaxy S8.
Photo of Ryanb58

Ryanb58

  • 82 Points 75 badge 2x thumb
  • unsure

Posted 11 months ago

  • 2
Photo of Derrick S.

Derrick S., Official Rep

  • 7,644 Points 5k badge 2x thumb
Hi Ryanb58,

Can you send an email to help@automatic.com for assistance with this?