Any update on timeframe for support of DashCommand for Automatic Pro?

  • 4
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

I had purchased the Automatic Pro because the original advertisements showed DashCommand as one of the supported apps. Apparently, that support has since been removed.

Is there any timeframe for when DashCommand support will be added for Automatic Pro? Is this because of a limitation on DashCommand side? If so, I can give some feedback back to DashCommand developers.

I'm tempted to return my Pro and go back to the Automatic G2 since I really miss DashCommand. 

I know that ODBFusion is supported, but I feel DashCommand has a much better user interface and displays.
Photo of scott k

scott k

  • 140 Points 100 badge 2x thumb
  • frustrated

Posted 2 years ago

  • 4
Photo of Nick

Nick, VP, Engineering

  • 1,982 Points 1k badge 2x thumb
Hi Scott

The Automatic Pro will logically still work with Dash Command - we have not had the time to formally qualify anything but OBD Fusion however and we know the firmware on the Automatic Pro will need a little tuning to get the Pro to work exactly the same as the Gen 2 product.

As you're an owner of Dash Command and a Pro, please give it a whirl and let us know how it goes!

Thanks,

Nick.
VP, Hardware and things
Photo of scott k

scott k

  • 140 Points 100 badge 2x thumb
I tried it but only the speed PID/gauge seems to be working. Dash commander shows "N/A" for any other gauges other than MPH. No MPG, RPM, fuel rate, O2, etc.

On the same car and iPhone, all gauges worked previously with Automatic G2 and Dashcommand.

Any settings tweaks to try?

Thanks.
Photo of Nick

Nick, VP, Engineering

  • 1,982 Points 1k badge 2x thumb
Scott,

Try:

- change the max PID response timeout to 1000ms
- re-validate the PIDs (after the above)
- then bring the max response timeout down depending on your car (400ms might be a good value to get 5 PIDs on your car's protocol - ISO)

Thanks,

Nick.
VP, Something or other
Photo of Joseph

Joseph

  • 334 Points 250 badge 2x thumb
I have yet to try it with my new Pro, but I just want to chime in that support for Apps like Dash Command are also one of the main reason's I bought an Automatic G2 and Now a Pro. Please get this working in full soon. Also been a diligent Beta tester still waiting for the adapter to be able to connect to two devices at once, so I can have Dash Command on an iPad but Automatic logging on my phone. 
Photo of Nick

Nick, VP, Engineering

  • 1,982 Points 1k badge 2x thumb
Joseph,

Try connecting your iPad to the Automatic Pro (in BT settings). You might need to click on the BT device to connect every time you start you car, but it should work. 

Note - totally unsupported feature and mileage may vary in your success (but it works well for me!) :)

Let us know how it goes.

Thanks,

N
VP, Things and stuff
Photo of scott k

scott k

  • 140 Points 100 badge 2x thumb
Why is connecting to Dashcommand an unsupported feature now? This feature was advertised in the email advertisements I received which is why I purchased the Pro.

And having to manually connect to the adapter every time I start the car seems like step back in functionality. The Automatic adapter use to do this seamlessly.
(Edited)
Photo of Amy

Amy

  • 68,970 Points 50k badge 2x thumb
My understanding -- and Nick can correct me if he sees this & I'm wrong -- is that there's some work involved that would require participation from DashCommand which isn't currently on their roadmap. This wasn't clear to those of us doing initial communication about the Pro at the time of launch. We thought that it would be supported.

OBDFusion has done the work to help make the integration work with Pro, though, so that's the one we're officially listing in our App Gallery now. 

This conversation is no longer open for comments or replies.