Excessive battery usage is back

  • 1
  • Problem
  • Updated 1 month ago
I posted a one-star rating on Google Play for the app initially because of extremely excessive battery usage even when not driving. It was a GPS wakelock issue as far as I could tell. It was eventually resolved and I updated my rating.

Over the past few days I am once again seeing background wakelocks by Automatic causing excessive battery usage. Last night I sat down to check what had been causing my insane battery usage and noticed Automatic was in double digits with over nine and a half hours of background activity time.

I'll update this ticket as I can test over the next few days. I've disabled location permissions in Automatic today to see if the excessive battery issue persists. That was my workaround for the original bug.

Also there appears to be a bug here in the issue tracker as I tried submitting this once, it request I log in, and the ticket it loaded was empty.
Photo of Chris Clemons

Chris Clemons

  • 130 Points 100 badge 2x thumb

Posted 1 month ago

  • 1
Photo of Derrick S.

Derrick S., Official Rep

  • 5,654 Points 5k badge 2x thumb
Hi Chris,

Thanks for posting this in the Community and please let us know what you find. As for the bug, you ended up posting twice, so I am not sure what happened there. If it happens again you would have to contact Get Satisfaction since they host. I will delete the (mostly) duplicate post. 
Photo of Chris Clemons

Chris Clemons

  • 130 Points 100 badge 2x thumb
Look like it is indeed a GPS issue. Disabling location permissions for the app completely eliminated the idle battery usage by Automatic.

This is on a Google Pixel running stock Android 8.1.0
Photo of Chris Clemons

Chris Clemons

  • 130 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Excessive battery usage is back..

I posted a one-star rating on Google Play for the app initially because of extremely excessive battery usage even when not driving. It was a GPS wakelock issue as far as I could tell. It was eventually resolved and I updated my rating.

Over the past few days I am once again seeing background wakelocks by Automatic causing excessive battery usage. Last night I sat down to check what had been causing my insane battery usage and noticed Automatic was in double digits with over nine and a half hours of background activity time.

I'll update this ticket as I can test over the next few days. I've disabled location permissions in Automatic today to see if the excessive battery issue persists. That was my workaround for the original bug.