iPhone X and Automatic - Loss of Bluetooth

  • 4
  • Problem
  • Updated 8 months ago
Merged

This conversation has been merged. Please reference the main conversation: iPhone X and Automatic 2nd gen - error prompt over and over again on trying to connect

Long time Automatic user on my iPhone 6 for several years. Been running IOS 11 for some time with no problems connected to my 2016 Mazda CX-9.    

Just got my new iPhone 10 on Friday and having Bluetooth issues with my new phone. And ONLY when the connected to the Automatic.    With my new phone (Bluetooth 5) connects to both my Mazda audio and the Automatic, the phone consistently connects and disconnects from my car.    Been doing that since I re-registered my adapter to my new phone to my car on Saturday.   

I continually see the Car audio system report loss of Bluetooth and audio etc.  Finally decided to pull the Automatic from the ODB port and the problem stopped.   There seems to be some type of problem with the iPhone 10 (X) talking to the Automatic adapter and my car at the same time.  Seems like the phone struggles to talk to the automatic adapter, thus causing bluetooth to go crazy and my car dropping the connection.  But when there is no connection to the Automatic, I have zero problems.  

Is there a firmware update or some but with newer bluetooth?
Photo of Howard

Howard

  • 518 Points 500 badge 2x thumb

Posted 8 months ago

  • 4
Photo of Rob

Rob

  • 164 Points 100 badge 2x thumb
Exact same problem but I have new iPhone 8.
Photo of Howard

Howard

  • 518 Points 500 badge 2x thumb
I was surprised no one has reported the problem yet with the 8 as it's been out longer.  Definitely a problem. I sent an email to support, but no response yet.
Photo of Rob

Rob

  • 164 Points 100 badge 2x thumb
I have also reported my problem to support but was not given an ETA on a fix.  Please let me know if you receive any communication.
Photo of Ani

Ani, Customer Care Lead

  • 9,764 Points 5k badge 2x thumb
Hi all, we've just started testing with the iPhone X, our staff didn't receive theirs until today. Unfortunately 3rd party devs don't often get early access to new hardware like this so we're just now doing some initial testing. We can't promise when something will be fixed, but we're looking into some of the bugs people have been reporting. 
Photo of Howard

Howard

  • 518 Points 500 badge 2x thumb
Thanks Ani  
Photo of Bob Fairbairn

Bob Fairbairn

  • 84 Points 75 badge 2x thumb
I have an 8 Plus and a 2014 Camry.  I have been having trouble with the Audio on the car disconnecting.  I thought it might be the something messed up with the phone as I did an upgrade from my iPhone 7 Plus.  I restored the phone to factory last night and started testing today. What I found is that when the Automatic (gen 2) is connected the BT to the Camry disconnects every minute or so.  Sometimes it holds fine say if you are playing a podcast or music.  When I unplug the Automatic from the Car the audio connection holds fine and the phone does not disconnect.  

It may go back further to the iPhone 7 Plus as when I bough my 2014 Camry I did see some audio disconnects but they were intermittent. 

I have not done a full debug yet. Say leave the Automatic plugged in and just disconnect the Bluetooth connection or uninstall the App.

If you need some other help debugging in my environment let me know; I am glad to test.

Bob
Photo of Rob

Rob

  • 164 Points 100 badge 2x thumb
Hi Bob! I have found the same results. How do you keep the automatic plugged in, while keeping the phone from disconnecting/reconnecting constantly from the car? I have a 13 Camry with an iPhone 8. Thank you!
Photo of Bob Fairbairn

Bob Fairbairn

  • 84 Points 75 badge 2x thumb
The automatic seems to run fine you have to live with the audio system not working if you need the automatic to work.  I am not sure what I will do for now.
Photo of Rob

Rob

  • 164 Points 100 badge 2x thumb
Yeah, that’s not acceptable for me. Thanks for the research.
Photo of Howard

Howard

  • 518 Points 500 badge 2x thumb
Yeah. I’ll just give up my audio and hands free phone calls and all the other systems in my $50,000 car for a $100 car tracker. NOT!
Photo of Bob Fairbairn

Bob Fairbairn

  • 84 Points 75 badge 2x thumb
It may not be the automatic. I still have mine disconnected and I was having trouble again tonight with the iPhone 8plus disconnecting while playing a podcast in overcast...

This conversation is no longer open for comments or replies.