Real-time data stopped working

  • 2
  • Problem
  • Updated 10 months ago
Hi, I've been using a custom developed app that receives real time data from Automatic via the websocket API, it has been functioning fine for several months. Looks like it stopped receiving updates starting sometime yesterday evening. The Android App is working fine so there's no issues with the adapter or the data from the adapter reaching the Automatic servers.
Is this just me or is there a System wide problem?
Photo of xrak en

xrak en

  • 1,196 Points 1k badge 2x thumb

Posted 10 months ago

  • 2
Photo of Matt Farley

Matt Farley

  • 1,506 Points 1k badge 2x thumb
I keep a log of all my websocket events and on August 27th something happened where events started arriving late. Prior to Aug 27 I received the events within 60 seconds. After August 27th they are always 1-30 minutes late. Maybe this is related to your issue.
Photo of Derrick S.

Derrick S., Official Rep

  • 7,644 Points 5k badge 2x thumb
Hi exrak en,

Please contact developer@automatic.com for assistance with this.
Photo of Matt Farley

Matt Farley

  • 1,506 Points 1k badge 2x thumb
Actullay, xrak en -- I hadn't noticed, you're right. Events completely stopped yesterday, I haven't received anything in about 24 hrs.
Photo of xrak en

xrak en

  • 1,196 Points 1k badge 2x thumb
Hi Derrick, I sent in an email - no response so far. Hopefully someone will get a chance to look into it next week.
Photo of Matt Farley

Matt Farley

  • 1,506 Points 1k badge 2x thumb
Same here :(
Photo of xrak en

xrak en

  • 1,196 Points 1k badge 2x thumb
Started working again this morning. Derrick, was there an issue with the service at your server side?
Photo of Derrick S.

Derrick S., Official Rep

  • 7,644 Points 5k badge 2x thumb
Hi xrak en,

Not that I am aware of, the Developer Team would know more. We didn't have any outages for the regular Automatic service.
Photo of Matt Farley

Matt Farley

  • 1,506 Points 1k badge 2x thumb
Mine started working too. This is what I received from support:
Apologies the worker tied to your app had been having a lot of errors silently and we hadn't noticed. This has been restarted and alerting added so it shouldn't happen again. Events should be flowing normally now. Though. that said, a delay of a few minutes can commonly happen during peak concurrency (rush hour, 2x/day). We would consider anything less than 5mins within normal operations, though we strive for near real time.
Photo of xrak en

xrak en

  • 1,196 Points 1k badge 2x thumb
Glad they've got alerting added. This was the first outage for me (not counting the rather large latencies at times) and they got it resolved so I'm happy about that.
Photo of Josh Pritchard

Josh Pritchard

  • 60 Points
Hello xraken -- could we speak about this app you're using?  I want to get live events that I think were discontinued (from g2 to pro), and wonder if your app does this