Trying to install the app and I get a "device isn't compatible with this version" message. Now what?

  • 1
  • Question
  • Updated 6 months ago
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

My 3 year old Samsung/droid isn't compatible with Automatic Pro? That is what the Google store is telling me. Maybe I am trying to get the wrong app. THere are so many I am confused
Photo of Mike Forbes

Mike Forbes

  • 80 Points 75 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Amy

Amy

  • 68,970 Points 50k badge 2x thumb
Hi, Mike. What Android OS version are you on? The Automatic Pro app requires 5.0 & newer. If that's not the issue, though, can you please send us a screenshot of what you're seeing? If there's any private info in the screenshot, you can email it to help@automatic.com instead and let me know here that you've done so and I'll take a look. Thanks.
Photo of Craig Rutledge

Craig Rutledge

  • 80 Points 75 badge 2x thumb
I also got this message, on a Galaxy S7 running Android 7.0
Photo of Derrick S.

Derrick S., Official Rep

  • 7,634 Points 5k badge 2x thumb
Hi Craig,

That phone is absolutely supported, and there are a few reports of other users having the same issue. The problem lies with Google Play, which unfortunately means we don't have a way to fix it. I did some research and here is what Google recommends: 

"As a temporary workaround, Google suggests clearing Google Play Store's data from your phone and then trying to install the app. To do this, go to Settings > Application Manager > All > Google Play Store > Clear data."

I hope this helps!

This conversation is no longer open for comments or replies.