Websockets completely broken?

  • 1
  • Problem
  • Updated 5 months ago
Running into more problems with my app that uses the Automatic Websocket APIs.
The location:updated messages stopped on Dec 1 but I was still receiving other websocket messages. Starting yesterday (Dec 11) all messages stopped. When I try to send a simulated messaage from the developer portal I get this:
Ensure that you have a valid access token for this client with the required scopes for this event. Also ensure that the client's event delivery preference is set to either webhooks or websocket.
Nothing changed at my end other than that I had requested a scope change to get the location updated messages (received no response yet from Automatic for that). I tried resetting the client secret and updated my code with the new secret but still nothing. What do I do?

Matt: Are you receiving any websocket events?
Photo of xrak en

xrak en

  • 1,196 Points 1k badge 2x thumb

Posted 5 months ago

  • 1
Photo of Justin Rodino

Justin Rodino

  • 820 Points 500 badge 2x thumb
xrak en,

I am still receiving web hook events from the back end JAVA infrastructure, however if you re-requested more profile/location/device information, you might need to click the "generate test token for your account" button in the dev portal before the simulated events will work (they'll use this generated token to pass info back and forth).
Photo of Yves Racine

Yves Racine

  • 70 Points
I just tried again, and nothing works, still getting the same error:

08333940-0b71-4a74-aece-168cac0a10de 10:05:03 PM: error javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure
08333940-0b71-4a74-aece-168cac0a10de 10:05:03 PM: debug Swapping token [code:5fb2c8a14c8faa4c72c3c6eda8b2525f1e19ebb8, theAccessToken:46df3743-1fb6-4170-8edb-73bed18a44db, appId:08333940-0b71-4a74-aece-168cac0a10de, param1:swapToken, action:[GET:executeSmartAppGet, POST:executeSmartAppPost, PUT:executeSmartAppPut, DELETE:executeSmartAppDelete, OPTIONS:executeSmartAppOptions], controller:smartAppApi]
Photo of Matt Farley

Matt Farley

  • 1,464 Points 1k badge 2x thumb
Sorry, I was out of town for 3-4 weeks. I can confirm that I'm now receiving the location:updated events (in near-realtime). However, on my app dev portal, it shows I don't have access to that scope -- which contradicts what I'm seeing in the app behavior. 

Also, I have a helpdesk tickets opened from 4-6 weeks ago and still no reply. I get the feeling Automatic is understaffed at the moment.