Split trips and delayed text messages?

  • 2
  • Question
  • Updated 12 months ago
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

I drove my car on two trips today. Starting at 6:50AM and finishing around 8:30AM. Automatic strangely recorded them as 3 trips but has the times of the trips correct. However I have been getting significant delays in the text messages recently leading to some panic about my car being stolen! I have received 3 text messages today corresponding to the 3 trips it recorded but they came through at 2:02Pm and 4:25PM. Why is there an 8 hours delay telling me my car just finished a trip (making me think someone stole it!). The car has been in the same place all day, I have been in my office all day with perfect coverage on my cell phone. This has been happening a lot recently.
Photo of John Fearnside

John Fearnside

  • 90 Points 75 badge 2x thumb
  • frustrated and anxious.

Posted 2 years ago

  • 2
Photo of Amy

Amy

  • 68,970 Points 50k badge 2x thumb
Hi John. I assume you're talking about the push notifications sent by the app? (You mentioned "text messages" but they're not text messages)

I just checked with our server team and there's no known delay in our notification server today so I'm not sure what's causing this. When you say this is happening a lot recently, can you please clarify? When did this start happening? How often are your push notifications delayed? 

I think I found your account. If I'm looking at the right one, there are two cars listed. Which car do you have the Pro installed in?
Photo of John Fearnside

John Fearnside

  • 90 Points 75 badge 2x thumb
Ah thanks for your reply. It made me realize something. It's not you that sends me these text messages (I do mean text messages not push notifications), it's a ifttt recipe that does it. Apologies it's a problem with their service not yours. With all these IOT it's hard to remember how it's all tied together and what triggers what! Thanks for the reply.
Photo of Amy

Amy

  • 68,970 Points 50k badge 2x thumb
Ah! Ok, that makes more sense then. :) There actually was some lag during certain peak hours on the event triggers. Our server team recently did some tweaking to improve it somewhat and will be doing a bigger project this month that should improve it a lot. You may want to check out this other post about this issue.   However, the 8-hour delay is a lot more than the delays we know about. I just noticed another post in the community about this so I'll ask our server team to look into it. It's possible it's on IFTTT's side, but I'm not sure yet. 

Also, I realize you had a 2nd issue about 2 trips getting split into 3. Do you by chance of a hybrid? If so, what kind? 
Photo of cocoaman2121

cocoaman2121

  • 72 Points
Not to resurrect an old post, but I actually had the same issue with my commute to work this morning. It split it into three different trips and I believe it happened when I force-closed the app near the tail-end. I do drive a hybrid, a 2007 Honda Civic
Photo of Derrick S.

Derrick S., Official Rep

  • 7,654 Points 5k badge 2x thumb
Hi cocoaman, please email help@automatic.com so we can take a look for you.
Photo of Amy

Amy

  • 68,970 Points 50k badge 2x thumb
Hi again, John. Please follow this other post for updates about the delay in IFTTT messages. I'd merge yours over there but you have the other issue here of the split trip so I want to keep this topic open so we can figure that one out. 

This conversation is no longer open for comments or replies.